Issue:
When attempting to run any Cognos report in Digital Hive, you get an error that states:
Symptoms:
1. The same reports run in Cognos without any errors
2. When you clear the cache and cookies in your web browser or use an Incognito Window, the same reports run in Digital Hive as well.
You can determine this by running a Network trace within the browser. Start the Network trace and then click the Console tab, you will see the below error.
Cause:
The reason behind this is the cookie header size which will need to be increased on the Cognos side of things.
Resolution:
Please review this article published by IBM.
It states:
Summary
Attempting to log on to Cognos Analytics when passing credentials from a third-party source results in http error 431 Request Header Fields Too Large.
Environment
Windows IIS Gateway
Steps
Typically this is resolved by increasing the cookie header size that is allowed on the gateway/webserver side.
1. Click the bi folder under the ibmcognos application.
2. Double-click Request Filtering.
3. Click the Headers tab
5. Select the current Cookie header and select Remove
6. Select Add Header to add new Cookie header with a higher Size Limit.
7. Recycle IIS to ensure the change is picked up immediately
Additional Information
You can copy the cookie header from a browser network trace into notepad++ or other available tools to see the current length of the header. Doing so allows confirmation if you are exceeding the size or determine how much larger the size needs to be increased.